[cl-plus-ssl-devel] Simple test failed in ECL

Rafael Jesús Alcántara Pérez ralcantara at dedaloingenieros.com
Mon Sep 3 00:38:02 PDT 2012


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi all:

I'm trying to use usocket and cl+ssl with ECL but I have failed to run
the attached test (it fails raising a SEGMENTATION-VIOLATION condition
when evaluating make-ssl-client-stream).

By the way, the test runs fine on, at least, SBCL :)

Greets and thanks in advance.
- -- 
+----------
| Rafael Jesús Alcántara Pérez <ralcantara at dedaloingenieros.com>
| Director Técnico.
| Teléfono fijo: 952 602 959
| Fax: 952 602 959
| Dirección: C/ Afligidos 2, 3º Derecha, 29015 Málaga
| Dédalo Ingenieros, S.L.: http://www.dedaloingenieros.com/
| PGP: http://pgp.rediris.es:11371/pks/lookup?op=index&search=0x53F330AB
+---------------------
"For every complex problem there is a solution that is concise, clear,
simple, and wrong." (H. L. Mencken)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iEYEARECAAYFAlBEXloACgkQyR3/fFPzMKueRACgmwY89gk3EMOZ7PFZdTIHmWuk
NzYAn1vHvv55vnNLTeZuCQOO5tLvAFcI
=VtUy
-----END PGP SIGNATURE-----
-------------- next part --------------
(ql:quickload "usocket")
(ql:quickload "cl+ssl")

(defun test-ssl-sockets ()
  (let (stream-usocket ssl-stream)
    (format *debug-io* "connect: trying to connect to www.google.es...~%")
    (setf stream-usocket (usocket:socket-connect
                          "www.google.es"
                          443
                          :element-type '(unsigned-byte 8)))
    (format *debug-io* "connect: socket-stream is ~a.~%" (usocket:socket-stream stream-usocket))
    (setf ssl-stream (cl+ssl:make-ssl-client-stream
                      (usocket:socket-stream stream-usocket)
                      :external-format :utf-8))
    (format *debug-io* "connect: ssl-stream is ~a.~%" ssl-stream)))

(test-ssl-sockets)


More information about the cl-plus-ssl-devel mailing list